AnsweredAssumed Answered

AD9364 and updated image for ZEDboard not working

Question asked by Cman Employee on Oct 31, 2014
Latest reply on Nov 4, 2014 by chrislogic

Hi Lars and  friends

 

 

(a) Customer using the link and update the image  from Zynq Quick Start Guide [Analog Devices Wiki] . And after that the spectrum no longer work.

 

Please can you advise.

Regards,

Ching

 

Customer's issues ->

I am trying to get the spectrum display working in the oscilloscope application. I have used it successfully before with the SD card that was shipped with the FMCOMMS4-EBZ. The SD card is labelled ‘January 2014’.

I am using with a zedboard. Since I first tried it, I have used ‘ADI_UPDATE_TOOLS.SH’ and ‘ADI_UPDATE_BOOT.SH’ Since then I have not been able to show the spectrum display.

I have then down loaded the image ‘zynq_image_8gb_2013_12_12.img.xz’  .I use  the files for AD9361 because this image does not have any files for AD9364. With this I only see iio:device0 and iio:device1 but not the others.

If I again try ADI_UPDATE_TOOLS.SH twice and then ADI_UPDATE_BOOT.SH, the

system no longer boots and hangs with kernel panic.

Is there another SD image I could try that supports the FMCOMMS4 ?

So when I use this image as in (a) above , after creating the card, I have to copy the correct boot.bin and device tree files into the root. However, there is no option for the AD9364. The nearest match is a folder called ‘zynq-zed-adv7511-ad9361’ . If I copy the files out of here I only get iio:device0 and iio:device1

 

The original SD card that I received with the FMCOMMS4 worked ok but the image from your link does not seem to work for FMCOMMS4.

---------------------------

Outcomes