AnsweredAssumed Answered

ADE7880 - get negative values on xWATTHR, possive values on xVAHR using resistance load

Question asked by karens on Oct 8, 2014
Latest reply on Oct 20, 2014 by hmani

Hello,

 

Using ADE7880, set to 3-phase, 4 wire configuration. Using the resistance load, I always get the negative xWATTHR values, positive xVAHR. I set to use the Line cycle accumulation mode to get these energy values. 

 

Here is the settings (run in 60Hz):

1. Set LCYCMODE register to 0xBD; /* includes all 3 phases' half cycles */

2. Set LINECYC to 6*300 = 1800d (16.67ms * 300 = 5.001 seconds)

3. Set VLEVEL = 500.0 / 1.414 / 120.0 * 4 * 1000000 = 11786893

     where voltage is set to the gain of 1, 120.0 is the expected phase voltage.. Is it the reasonable value???

4. WTHR / VARTHR / VATHR are the default value, didn't change them

 

Then, when LENERGY bit is set at STATUS0 register, MCU reads xWATTHR and xVAHR regiseters:

 

AWATTHR = 0XFFFFE170, the readings are consistent.

AVAHR      = 0x00001E8F, the readings are consistent.  

 

BWATTHR = 0XFFFFE230, the readings are consistent.

BVAHR      = 0x00001DF2, the readings are consistent.

 

CWATTHR = 0XFFFFE1AC, the readings are consistent.

CVAHR      = 0x00001E76, the readings are consistent.

 

Do I set up anything wrong, I expected to get all positive energy values? Is it right?

 

I wonder if the content of register VLEVEL caused this issue. What is the primary functionality on WTHR / VARTHR / VATHR? Do I have to set up these registers? On equation 26, 37, 44, how should I determine the value of "n"?    

 

Thank you very much!

 

Karen

Outcomes