AnsweredAssumed Answered

Unable to build and debug a program in CCES and Image processing toolbox

Question asked by manjunath.a.n on Oct 9, 2014
Latest reply on Nov 20, 2014 by JohnPytlowany

Hi,


I installed CCES 1.1.0 and ImageProcessingToolbox-BF-Rel2.3.0 and tried to run an Image processing example program on my target board ADSP BF609 EZ kit.

Am getting error if i build the program. The error is as shown below.

 

[Error li1021]  The following symbols referenced in processor 'CORE_0' could not be resolved:

        'ADI_USBD_DEV_BF_MUSBMHDRC_API [_ADI_USBD_DEV_BF_MUSBMHDRC_API]' referenced from '..\..\..\..\Support-Modules\usbio-cces\bf609\lib\libucusbd.dlb[usbd_drv_adi.doj]'

 

Linker finished with 1 error

cc3089: fatal error: Link failed (code:1)

make: *** [bayer_bf609.dxe] Error 1

 

If i run the given pre-built .dxe (without build the program),

I got the debug messages as shown below and it is stopped after this.

Core clock:          500000000 Hz

System clock:        250000000 Hz

Core 0 system clock: 125000000 Hz

Core 1 system clock: 125000000 Hz

 

I have gone through the readme file in the example program.

There it is mentioned that,

Hardware/Tools Used: USB_ICE

Jumper Settings:

P1 : Not Connected (Default)

ZP1: Not Connected (Default)


But, am using Debug agent which is mounted on P1 and ZP1.

I tried it for other programs also. But getting same problem.


Please help me to solve this.

Outcomes