AnsweredAssumed Answered

Need help using Jdata in de-interlaced mode

Question asked by ahsoft71 on Sep 16, 2010
Latest reply on Sep 19, 2010 by DaveD

I am student working on video compression i have successfully implemented Jdata in interlaced mode and it is working but my application is low bit rate so i want to implement Jdata in de-interlaced mode now the problem is according to the datasheet and ADV212 i have changed the parameters of both encoder and decoder side and they are as under

 

encoder side

 

0x0901

0x0503

0x0300

0x0000

0x0100

0x30D4

0x0001

0x0002

 

decoder side

 

0x0901

0x0003

0x0000

0x0000

0x0011

0x0001

 

now the probelm is when the encoder is not attached to the decoder (which is interfaced though the CPLD for synchronization ) both the encoder and decoder are giving valid signals but when the data of the two boards(they are dedicated boards made by me) are attached with each other they run for few secs a we get some frames of valid video a then it stops and hold is arrested on both encoder and decoder. I am unable to solve the issue more over there is very little help available regarding de-interlaced mode.can you please explain the what are issues in de-interlaced mode as you have told in one of your threads about this that there are some timing issues in this mode and also tell me how can i trace what is the problem. I also want to tell you that the same boards are running perfectly in Jdata interlaced mode and in this mode i am using 0x0101 for both encoder and decoder  in place of 0x0901 rest of the parameters are the same. best regards

saqib

Outcomes