AnsweredAssumed Answered

Problems with adc_capture() for no-os with fmcomms2.

Question asked by Jetmiri on Aug 7, 2014
Latest reply on Aug 14, 2014 by CsomI

I am using No-os reference design for FMcomms2 with zedboard. I define the CAPTURE_SCRIPT and save the .elf file. But when I use my new created .elf file with capture script I see an error on XMD saying: ERROR: Cannot read from target. MMU section translation fault.

 

I run my .elf file on debug mode on the SDK and I see that there is an "infinit" loop inside the function adc_capture()  ( no-OS/adc_core.c at master · analogdevicesinc/no-OS · GitHub)  The program won't go aut the loop:


do {

adc_dma_read(AXI_DMAC_REG_TRANSFER_DONE, &reg_val);

}

while((reg_val & (1 << transfer_id)) != (1 << transfer_id));



So it seems that the script since the programm is running all the time can not reed from the target. Am I wrong or what is happening here!?


I tried to run the .elf file which is on the script folder ( no-OS/ad9361/scripts/zed at master · analogdevicesinc/no-OS · GitHub ) on SDK and I had the same "infinit" loop. But however the script works with this .elf file but not with my .elf file.


Any suggestions!?


Regards,

Jetmir.

 

Outcomes