AnsweredAssumed Answered

ADV7441A output color is wrong when receiving UXGA HDMI input

Question asked by Jane on Jul 30, 2014
Latest reply on Aug 4, 2014 by mattp

Dear Sir,

It is said in the datasheet that ADV7441A incorporates a dual-input HDMI-compatible receiver that supports  display resolutions up to UXGA.

When the customer use ADV7441A receiving 1600X1200@60Hz HDMI input, the output color is wrong (during some tests the output display is green, some tests the output display is colorless). The attached pics are about ADV7441A abnormal output.

 

Below content is the script which is used now. Is there any necessary content should be modified when the input signal is UXGA (f >160MHz)? Also tested HDMI input resolution lower than 1600X1200@60Hz, the output works very well.

 

 

##HDMI PORTA out through ADV7341 Encoder ##

:Port A 1080i 60Hz 25Mhz <  f < 160MHz  YPrPb 422 20Bit IN YPRPB 422 20Bit OUT through Encoder cable Equalizer:

50 10 06 ; Encoder output channel enabled ?36 Bit

50 11 05 ; Bus reordering

50 19 01 ; ADV7441A Video Input Module

50 1B 02 ; Rev E Video Output Module

50 03 03 ; Enable Port A

42 03 0C ; Disable TOD

42 05 06 ; Prim_Mode =0110b HDMI

42 1D 40 ; Disable TRI_LLC

42 6B D1 ; Setting cp_op_sel = 1. 656 Enabled

42 68 F0 ; Auto CSC , YPrPb out

42 F4 3F ; Max Drive Strength

42 BA A0 ; Enable HDMI and Analog in

42 C8 08 ; Digital Fine Clamp Start position

62 F0 10 ; ADI Recommended Write

62 F1 0F ; ADI Recommended Write

62 F4 20 ; ADI Recommended Write

6A 15 EC ; Disable these mute mask bits

6A 1C 49 ; Set MCLKOUT to output 256fs

6A 1D 04 ; & Set Unmute Delay to 1_5 sec.

6A 5A 01 ; Reset Audio Pll

 

Best Regards!

Jane

Outcomes