AnsweredAssumed Answered

ADI Linux version that works with FMCOMMS2 Vivado 2013.4 on ZedBoard

Question asked by skp on Jul 23, 2014
Latest reply on Sep 24, 2014 by larsc

Hi

 

Able to build the the bit file for the "./ADI/vivado/projects/fmcomms2/zed" in the latest from "analogdevicesinc/hdl · GitHub". However when I use with the uImage from the reference design, it boots up with HDMI etc. O.K. but the FMMCOMMS2 is not recognized. The boot message indicates that there is  version mismatch between the drivers and pcores.

 

Tried rebuilding the uImage with the master branch (xcomm_zynq) of  "analogdevicesinc/linux · GitHub". The new kernel boots up O.K. without error, but apparently the IIOScope application shows that it couldn't find the devices!

 

Would appreciate if you could post the combination of (git) version tags of the "Vivado HDL", "ADI Linux", XILINX Tool Version and other dependencies that are known to work for you.

 

Regards

SKP

Outcomes