AnsweredAssumed Answered

Problems with .dts while booting Linux on custom hardware

Question asked by resalmon on Jul 16, 2014
Latest reply on Jul 21, 2014 by larsc

Hello everyone!

 

I have a question on Linux.

After I succeeded booting Linux on ADV7511 Reference Design on my Zedboard I created custom Reference Design with only I2C and SPI outputs from the PS. It has no devices in the PL connected to the PS.

I've done everything like usual:

.bit - file in Vivado;

fsbl - file in SDK;

u-boot - like it is told in Analog Devices tutorial.

I have also managed to compile uImage and develop a custom .dts for my hardware.

So now it reads u-boot o'k, but while starting kernel I get this error:

-----------------------------------------------------------------------

Starting kernel ...

 

Error: unrecognized/unsupported device tree compatible list:

[ 'xlnx,zynq-7000' ]

 

Available machine support:

 

 

ID (hex)        NAME

ffffffff        ARM-Versatile Express

000008e0        ARM-Versatile Express

00000d32        Xilinx Zynq Platform

 

 

Please check your kernel config and/or bootloader.

-----------------------------------------------------------------------

My custom devicetree is attached.

I've already tried changing the compatible parameter to "xlnx,zynq-zed" and it worked in the same way. And I've also tried to change it to "xlnx,zynq-zc702" just in case, but in couldn't find a clock source.

Can anyone help me?

Attachments

Outcomes