AnsweredAssumed Answered

Booting an ADSP-21479 in spi slave mode

Question asked by Hans on Jul 3, 2014
Latest reply on Jul 7, 2014 by Hans

Hi there,

 

i tried alot right now but still can't get it running. I try to boot an ADSP-21479 (BGA196) with an external µC (cortex-M0). I read some things i could find about this matter but the most things involved the VisualDSP++ IDE.

I'm using the CrossCore IDE in Version 1.0.3 and things a little different there. I follow the instructions in the CCES loader manual and the 214xxx hardware reference.

 

My SPI interface is configured to mode 3 CPOL=1 and CLK=1 as defined in the hw reference. I can scope my transmission and everything seems to be fine. My Bitrate is 400kbits at the moment. I send all data continuously without any break.

 

In the hw reference it is denoted that the MISO pin can be used for handshaking and the slave will return 0's or 1's !?! (page 24-15) if a pause is required. Is this an error in the manual ? it would be nice to know what exactly an ADSP-21479 will transfer at the MISO pin when a pause is required. In my case the pin is always 1 during transmission.

 

I cannot monitor the RESETOUT pin because i have a custom board on which this pin is not reachable for me.

 

I have written a piece of code which blinks and LED on my custom board and the program work if i load it and debug it via JTAG. The Project is also attached.

 

My current booting procedure is:

- Reset

- wait 1s

- Send all data from the .ldr file

 

I also tried loading just the first 1536 bytes from the boot kernel, wait 10ms, then load the rest. But nothing works after that.

 

I'm also not sure how to just attach to the core using CCES. I tried by declaring to load "no image" in the debug settings but even after a full reset with power off i see data in the memory browser and dissasembly view (at adress 0x8c000 for example) which can't be true i think.

 

I'm glad about any suggestions

 

best regards

Attachments

Outcomes