AnsweredAssumed Answered

I have some troubles when I use CM408 and would somebody do me a favor ?

Question asked by tommychen on Jun 28, 2014
Latest reply on Jul 10, 2014 by John_M

Hello !

 

I have some troubles when I use CM408 and would somebody do me a favor ?@Kelven.Mo

 

     1,The SYS_FAULT pin will indicate fault(output low) when power on or after manual reset(by pulling down SYS_HWRST).

 

     2,When click "down load and debug"  command in IAR,an error will occur as below

 

 

Fri Jun 27, 2014 18:00:58: Loaded macro file: C:\Program Files\IAR Systems\Embedded Workbench 7.0\arm\config\flashloader\AnalogDevices\FlashCM40z.mac

Fri Jun 27, 2014 18:00:58: JLINK command: ProjectFile = F:\ZJL\云盘同步文件夹\项目-140224-CM40X\software\CM40X_EVB\CM40X_EVB_ADC\Dual_channels_3PhaseSampling\settings\

Dual_channels_3PhaseSampling_Debug.jlink, return = 0

Fri Jun 27, 2014 18:00:58: Device "ADSP-CM407BSWZ-BF" selected (2048 KB flash, 64 KB RAM).

Fri Jun 27, 2014 18:00:58: DLL version: V4.84c, compiled Apr 16 2014 18:53:07

Fri Jun 27, 2014 18:00:58: Firmware: J-Link ARM Lite V8 compiled Jul  8 2013 18:37:55

Fri Jun 27, 2014 18:00:58: Selecting SWD as current target interface.

Fri Jun 27, 2014 18:00:58: JTAG speed is initially set to: 1000 kHz

Fri Jun 27, 2014 18:00:58: Found SWD-DP with ID 0x2BA01477

Fri Jun 27, 2014 18:01:08: Fatal error: Error while identifying Cortex-M core.   Session aborted!

Fri Jun 27, 2014 18:01:08: Failed to load flash loader: C:\Program Files\IAR Systems\Embedded Workbench 7.0\arm\config\flashloader\AnalogDevices\FlashCM40z_2048.flash

Outcomes