AnsweredAssumed Answered

trouble compiling with Blimp ADV7625 OSD IDE and Emulator

Question asked by ronmusic on Jun 26, 2014
Latest reply on Jul 9, 2014 by JeyasudhaMuthuPerumal

Folks,

 

I'm having a lot of trouble getting almost anything working in the ADV7625 OSD emulator.

 

Two big questions; then I'll describe the problems I'm having:

- How *should* I be able to install MinGW and 7-zip?

- When there's a compiler error, the console log refers to a "log":  "please check log for errors."  Where is this compiler log?  (Screen shot 4.)

 

I seem to be having 2 categories of problem:  what happens when I let Blimp download MinGW by itself, and what happens when I download MinGW myself, from SourceForge:

- When Blimp downloads MinGW, it can't find the "7-zip decompressor," even after I've installed 7-zip myself.

- When I install MinGW myself, from SourceForge, I can make the Emulator run in exactly 2 cases:  creating a 1-page project, and dragging a simple Label onto it; and changing that label programmatically.  Everything else I've tried generates compiler errors.

 

 

Here are some situations where I generate compiler errors.  See attached screen shots.  These are all using the MinGW I downloaded from SourceForge.

 

 

shot 1)  Open the Blimp demo project.  Choose "Emulate."

 

Error:  "Unexpected problem during the compilation of the fonts."

 

 

shot 2)  Project has 1 page.  I dragged a default OSDImage from the toolbox onto the page, and chose "Emulate."

 

Error:  "Colorindex is not a valid in selected color table.  Errors during the creation of the master image buffer."

 

 

shot 3)  I tried to make a color table for situation #2.

 

Error:  "Index was out of range.  Must be non-negative and less than the size of the collection."

and:  "Error while building resolutions."

 

 

shot 4)  Make a new project.  Project has 2 pages.  Each page has a label.  During OsdPagePage1_Load(), programmatically change to page 2, using the command

 

    OsdApi.ADIAPI_OSDEgShowPage (PageManager.Page2, 10);

 

Error:  "undefined reference to OsdPagePage1_Create".

 

The documention doesn't mention a "Create" method or event.

 

So I tried defining it myself, using various combinations of the method name and modifiers, like this:

   public void Create () {}

   public void OsdPagePage1_Create () {}

   public static void Page1_Create () {}

   private void OsdPagePage1_Create () {}

   private static void Create () {}

 

...etc.  None of them made the error go away.

 

 

shot 5)  Make a new project.  Project has one page with one label.  Change the label's size to 14 point.

 

Error:  "font size cannot fit in memory and font size has to be reduced."

 

(Maybe this is normal for this platform, though...?)

 

 

Thanks, very much, for your help.

 

Ron

Outcomes