AnsweredAssumed Answered

CCES 1.0.3 Memory browser issue

Question asked by MikeSmithCanada on Jun 5, 2014
Latest reply on Jun 10, 2014 by DavidS

I have a library project myLib.dlb

 

volatile int dummy1 = 1;

volatile int dummy2 = 2;

volatile int dummy3 = 3;

 

void Somefunction(void) {   Some code }

 

and I have a main.cpp that is linked to that library using a path set in settings | linker |general

 

extern volatile int dummy1;

extern volatile int dummy2;

extern volatile int dummy3;

volatile int dummy4 = 4;

 

void main(void) {

     printf("%d %d\n",  dummy1, dummy2);

}

 

I can compile and run the code

 

Then I reload the code and ask the memory browser to find and display no problems

But the memory browser can't find dummy1

 

I generate a map and could find dummy1 in both name mangled and non-name mangled form

 

Wondering if it was a name mangling issue I tried
both

extern "C++"  volatile int dummy1;

extern "C"  volatile int dummy1;

 

in both case Memory Browsaer could now find dummy1

 

so I went back to

extern volatile int dummy1;
-- and that worked --

however none of these tricks worked with dummy2 and memory browser

 

I have tried clean and refresh on the project -- nothing helps

 

This is the first step of my group trying to access variables from a CCES plugin we are making -- but if I can't access the variables via memory browser then I suspect I am not going to get anything working from inside the plugin

Outcomes