AnsweredAssumed Answered

Troubles getting current values with Rogowski Coil (ADE7880)

Question asked by p301 on May 26, 2014
Latest reply on Jun 4, 2014 by dlath

Hi,

 

I am still working on my energy meter.

During my tests I found this issue when I was measuring currents with a Rogowski Coil.

I set the register DICOEFF to the value 0x0FFF8000 (I also tried to set DICOEFF to 0xFF8000 with the same results). Then I set the CONFIG register to 0x03 in order to enable the integrators.

But when I try to read currents the values of the registers (AIRMS, BIRMS and CIRMS) changes constantly.

 

I tried with the Rogowski on my desk (without anything inside) and I was expecting a values of the registers close to 0 as no current go through the Rogowski Coils. But the values changes from 760 to 8000 without reason (like in phase A 8000, in phase B 760 and in phase C 2000).

I also noticed when I enable the integrators the values of the registers rise significantly during the first measurement (about 600000 in each phases).

 

Note : In the Phase A,B and C data path all my Jumpers are Open. All the other inputs are floating

Note2 : If I do my measurement as I had a current transformer (so I don't set DICOEFF and CONFIG) my current values are 900 in each phases.

Note3 : If I try to read the currents with the AD's software (I enable the integrators in the software) I always get 900 in my registers. So it seems like there is a difference between the setup in the AD software and what I did.

 

Did I missed a step ?

 

Thanks for your help.

Regards,

Pierre

Outcomes