AnsweredAssumed Answered

ADV7281-M driver porting to linux 3.8

Question asked by kumarn on May 21, 2014
Latest reply on May 21, 2014 by larsc
Branched to a new discussion

I have downloaded driver for adv7281-m from https://github.com/analogdevicesinc/linux/blob/adv7280/drivers/media/i2c/adv7180.c & using it.

Iam compiling this for linux 3.8;I got compilation errors wherein v4l2_async_register_subdev(sd) & v4l2_async_unregister_subdev(sd) are not being defined & also MEDIA_ENT_T_V4L2_SUBDEV_DECODER not defined in 3.8;

I have commented these lines are proceeding with the build.Hope its should not have any issues,please confirm

Outcomes