AnsweredAssumed Answered

NO-OS driver + console application not working 100%

Question asked by rgetz Employee on May 13, 2014
Latest reply on May 27, 2014 by DragosB

Someone by email asked me:

 

We have gotten past the point where we want to use the demo board with the canned GUI to evaluate the part, and are now trying to use the No-OS software(that you can get from the ADI wiki) in order to move forward with integrating the tuner.  Specifically we are running Linux on a raspberry PI board, and controlling the tuner (stand alone at first) via SPI from the PI. 

 

We do have the console application running on the PI, and the communication via SPI to the tuner is working.  With that we can bring up the tuner and test it in its default configuration.  Obviously we would like to change the settings so that it operates in our desired frequency with our desired bandwidth, but we have having trouble getting the console commands to work.  We do have some working (after some debug), but not all of the needed ones are there yet.  Just to give you an idea, this is what we have working currently:

 

rx_lo_freq  read and write work

tx_lo_freq read and write work

rx_rf_bandwidth read and write work

tx_rf_bandwidth read works  

rx_samp_freq read works

tx_samp_freq read works

 

 

This is what we are still unable to change:

 

tx_rf_bandwidth write does NOT work

rx_samp_freq write does NOT work

tx_samp_freq write does NOT work

 

Has anyone tested this?

 

Thanks

-Robin

Outcomes