AnsweredAssumed Answered

Vivado ZED project no I2C connection to ADV7511

Question asked by Dmi on May 4, 2014
Latest reply on Oct 30, 2014 by mhennerich
Branched from an earlier discussion

Same problem.

 

- I checkout latest HDL libraries and project scripts from https://github.com/analogdevicesinc/hdl

- Built HDL libraries and ADV7511 for ZedBoard using Vivado 2014.1 - I just needed to update versions on couple Xilinx IP: for Zynq CPU from 7:5.3 to 7:5.4; for ConCat IP from 1.0 to 2.0 and for VDMA from 6.1 to 6.2.

Checked changelog - all changes seems to be minor.

 

After that I followed instructions from http://wiki.analog.com/resources/tools-software/linux-drivers/platforms/zynq

- Built BOOT.BIN

- Built Kernel from https://github.com/analogdevicesinc/linux.git using xcomm_zynq branch.

- Built DeviceTree.dtb using zynq-zed-adv7511.dts

- Prepared SD card with Linaro.

 

System boot normal, but nothing on screen. During boot it looks like it can't talk to ADV7511:

--------------------------------

i2c /dev entries driver

adv7511 0-0039: Failed to write 98 = 3: -110

adv7511: probe of 0-0039 failed with error -110

------------------------------

But sound seems to be detected:

-------------------------------

drivers/gpu/drm/adi_axi_hdmi/axi_hdmi_drv.c:axi_hdmi_platform_probe[197]

platform 70e00000.axi_hdmi: Driver axi-hdmi requests probe deferral

platform leds.6: Driver leds-gpio requests probe deferral

adv7511-hdmi-snd adv7511_hdmi_snd.4: ASoC: CODEC (null) not registered

platform adv7511_hdmi_snd.4: Driver adv7511-hdmi-snd requests probe deferral

drivers/rtc/hctosys.c: unable to open rtc device (rtc0)

ALSA device list:

  #0: ZED ADAU1761

-----------------------------

 

i2cdetect found 0x3b device, which is ADAU1761, but no 0x39 (ADV7511).

 

This all I got so far. Any suggestion? Should this combination of latest HDL and latest kernel work?

 

P.S. My hardware is fine - I see double Linux logo on HDMI monitor when I boot using ZedBoard OOB(out of box) image.

Outcomes