AnsweredAssumed Answered

ADXL375 Multi-byte read not functioning correctly

Question asked by ivran on Apr 16, 2014
Latest reply on Apr 17, 2014 by ivran

Hey guys, I'm having an odd issue with performing multi-byte reads on the data registers of my ADXL375. I'm communicating with the ADXL375 over SPI (4 wire) using a PIC24F32KA302 microcontroller, and I can correctly do single-byte reads on all the registers perfectly fine, as well as write data to the configuration registers. However, when I add that extra MB bit to read all the data registers in one transmission, the entire accelerometer goes nuts. Not only do I get bad data for the MB read, but single byte reads stop working as well! (Until I remove power from the system) I've tried this at just about every SPI clock speed and data output rate combination imaginable, and I still get the same results. I've examined this issue using an oscilloscope, and the clock, CS, and SDO from the PIC all look perfect, but the SDO from the 375 spits out garbage data as soon as that MB read command is issued. Anyone have any ideas? Thanks!

Outcomes