AnsweredAssumed Answered

ADV212 1080p60 (Part 2)

Question asked by J_Miller on Apr 2, 2014
Latest reply on Apr 7, 2014 by J_Miller

For Reference see previous question involving the Encoder side (http://ez.analog.com/message/136963#136963).

 

I am now on the Decode side of this problem.  I can generate 4 valid JPEG2000 compressed files (Y-Left, CbCr-Left, Y-Right, CbCr-Right), and have verified each with a software decoder.

 

I have modified my current FPGA that use to handle 2 ADV212 to now handle 4 ADV212 and all of the data and DMA signals look correct, but after 540 frame both ADV212s that handle CbCr data stop requesting data in the middle of an image and never request data again (until reset).  I am using the latest version of the ADV212 Decoder Firmware (decode_2_16_1.sea).

 

Also, I am decoding a solid color frame, which results in the compressed Y data fitting in 2x 32word bursts and the compressed CbCr data fitting in 3x 32word bursts.

 

Any insights into what this might be?

 

See Parameter Vales below (Master ADV212):

Set XTOT: 044C0000

Set YTOT: 04660000

Set F0_START: 00010000

Set F1_START: 00000000

Set V0_START: 002F0000

Set V1_START: 00000000

Set V0_END: 04660000

Set V1_END: 00000000

Set PIXEL_START: 00010000

Set PIXEL_END: 03C00000

Set PMODE2: 003F0000

Set VMODE: 00810000

 

 

See Parameter Vales below (Slave ADV212s):

Set XTOT: 044C0000

Set YTOT: 04660000

Set F0_START: 00010000

Set F1_START: 00000000

Set V0_START: 002F0000

Set V1_START: 00000000

Set V0_END: 04660000

Set V1_END: 00000000

Set PIXEL_START: 00010000

Set PIXEL_END: 03C00000

Set PMODE2: 003F0000

Set VMODE: 00800000

Outcomes