AnsweredAssumed Answered

ADV7611: HDMI input signal is not detecting

Question asked by siva.thiru on Mar 27, 2014
Latest reply on Apr 17, 2014 by GuenterL

Hi,

 

I am using below mentioned chips and configuration for HDMI.

ADV7611 - HDMI Receiver

ADV7513 - HDMI Transmitter

 

HDMI Receiver input signal is generated from PCIe based HDMI/DVI adapter card.

HDMI Transmitter output is connected to DVI monitor through HDMI to DVI adapter cable.

 

I have configured as FPGA loop back of HDMI receiver output to HDMI transmitter and following signals are directly loop back via FPGA.

 

HDMI Receiver                        HDMI Transmitter

 

HDMI_Rx_LLC                          HDMI_Tx_LLC                                                                        

 

HDMI_Rx_HS                            HDMI_Tx_HS

 

HDMI_Rx_VS                            HDMI_Tx_VS

 

HDMI_Rx_DE                            HDMI_Tx_DE

 

HDMI_Rx_D[0:23]                      HDMI_Tx_D[0:23]

 

I followed the ADI recommended register settings for both ADV7611 and ADV7513.

In ADV7611 and ADV7513,  all the registers I2C read and write operation working properly and i am able to configure the register for default blue or green or red screens. But HDMI receiver input signals is not detecting.

If any other setting is their to enable the detection  the HDMI input signals in ADV7611.

 

HPA_AINT2(hot plug detect) comes to 5V and RXA_5V pin also comes to 5V.

But clock signal is not coming in RXA_C+,RXA_C- and Data signals also is not coming in RXA_0-,RXA_0+,RXA_1-.RXA_1+,RXA_2_,RXA_2+ pins.

 

Thanks,

--Siva--

Outcomes