AnsweredAssumed Answered

Unexpected ordering in the library search directories list for the linker

Question asked by JohnRedford Employee on Mar 25, 2014
Latest reply on Mar 27, 2014 by CraigG

I was experimenting with two different versions of the same routine in different libraries.   I had a path to each library directory, and would change the order to test one or the other.  The two paths were:

 

"${COM_ANALOG_SWMODULE_IMAGEPROCESSINGTOOLBOX_BLACKFIN_2_3_0_LOC}/Lib-Production-CCES"

../../../../c_ref/Debug

 

The order is specified in Project Properties, C/C++ Build->Settings->Tool Settings->CrossCore Blackfin Linker->General .   I found that the Debug directory was always put last on the list no matter where I had it in the Library Search Directories box.  It turned out that it needed to have double quotes around it like the other directory entries.   Leaving off quotes caused it to always be at the end.   Adding the quotes fixed it, but wasn't obvious!

Outcomes