AnsweredAssumed Answered

Linux driver for the Vivado AD9361 Interface Block in Linux

Question asked by Dan_Fay on Mar 20, 2014
Latest reply on Mar 20, 2014 by mhennerich

Hello,

 

I successfully built the bitstream for the Vivado version of the Zed/FMCOMMS2 reference design.  While I don't get any freezes or kernel panics from the bitstream, I get the following message from the kernel on bootup:

 

ad9361 spi32766.0: ad9361_probe : AD9361 Rev 2 successfully initialized

cf_axi_dds_so 79024000.cf-ad9361-dds-core-lpc: Major version mismatch between PCORE and driver. Driver expected 6.00.a, PCORE reported 7.00.a

 

Last time I had this issue, I was told to update to the latest HEAD revision in the Git repo.  When I did that today, I still got the version mismatch error. 

 

Where I might find the right Linux driver version?

 

Thanks!

 

-Dan Fay

Outcomes