AnsweredAssumed Answered

Wrong mode register value from AD7730

Question asked by linupa on Mar 19, 2014
Latest reply on Apr 9, 2014 by ChrisD.Rama

Hi, I'm using AD7730 evaluation board to measure a load cell data.

 

I connected AD7730 to our microcontroller, but there are some problems.

 

When I tried to read the status register, I read '0xC7' value, and it seems to be OK.

 

However, when I tried to read the mode register, I read '0x0140'. The second '1' in the value is on "Zero field" should be zero.

 

I read the register just after the system is turned on.

 

Currently, nothing bu the 9-pin connector is connected to the board. The jumpers on the board are in default setting.

 

In 9-pin connector, I connected DIN, DOUT, CLK, CS pins to the microcontroller. RESET is high, VDD is +5V, and GND is 0V.

I read RDY pin, but it is always high.

 

I attached signals from the oscilloscope while reading mode register, and it shows very clean data '0140'. The clock period is 800usec.

 

I also tried to change the mode register, but nothing didn't change. The mode register shows always '0140'

 

Thank you,

Kwan Suk Kim

Attachments

Outcomes