AnsweredAssumed Answered

Power on AD-FMCOMMS2-EBZ from ZC702

Question asked by Ed_V Employee on Mar 5, 2014
Latest reply on Mar 5, 2014 by rejeesh

After debugging it looks like the power rail for the xcvr chip (ad9361)on the eval board is not getting the power good signal (PG-FMC) from the ZC702 board (should be asserted highand it’s not). As a result there’s no power going to the ad9361. And we get thefollowing error upon boot:

 

platform 79020000.cf-ad9361-lpc:Driver cf_axi_adc requests probe deferral

ad9361 spi32766.0: ad9361_probe: enter

usb 1-1: new low-speed USB device number 2 using xusbps-ehci

ad9361 spi32766.0: ad9361_probe: Unsupported PRODUCT_ID 0x0

ERROR: could not get clock/fpga-axi@0/cf-ad9361-dds-core-lpc@79024000:sampl_clk(0)

platform 79024000.cf-ad9361-dds-core-lpc: Driver cf_axi_dds_so requests probe deferral

adv7511-hdmi-snd adv7511_hdmi_snd.6:  adv7511 <-> 75c00000.axi-spdif-tx mapping ok

TCP: cubic registered

NET: Registered protocol family 17

Registering SWP/SWPB emulation handler

input: Logitech USB Optical Mouse as /devices/amba.1/e0002000.usb/xusbps-ehci.0/usb1/1-1/1-1:1.0/input/input0

hid-generic 0003:046D:C077.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-xusbps-ehci.0-1/input0

Console: switching to colour frame buffer device 200x56

axi-hdmi 70e00000.axi_hdmi: fb0:  frame buffer device

axi-hdmi 70e00000.axi_hdmi: registered panic notifier

[drm] Initialized axi_hdmi_drm 1.0.0 20120930 on minor 0

platform 79020000.cf-ad9361-lpc: Driver cf_axi_adc requests probe deferral

ERROR: could not get clock /fpga-axi@0/cf-ad9361-dds-core-lpc@79024000:sampl_clk(0)

platform 79024000.cf-ad9361-dds-core-lpc: Driver cf_axi_dds_so requests probe deferral

rtc-pcf8563 5-0051: low voltage detected, date/time is not reliable.

rtc-pcf8563 5-0051: retrieved date/time is not valid.

rtc-pcf8563 5-0051: hctosys: invalid date/time

ALSA device list:

 

I followed the directions on the ADI wiki page to create the SD card with the Xilinx image and moved the ad9361 boot.bin and devicetree to the main boot partition. The Xilinx board does see the eval board and the AD7291BCPZ, and can even read it’s voltages but not the ad9361.

 

Is there a step I’m missing to turn on the 1.3V and 1.8V supplies for the AD9361?

 

Thanks

Outcomes