AnsweredAssumed Answered

A question about the Rising/Falling Sweep Ramp Rate of AD9915

Question asked by Sercan on Mar 3, 2014
Latest reply on Apr 1, 2015 by abarry

Hi,

 

With AD9915 Ev.Board we observe that the Rising/Falling Sweep Ramp Rate of AD9915 is operating 2/3 of its programmed value.

(For ex. When we programme 100 us, we observe 67 us.)

What can be the reason of this situation. Do you have any idea?

 

Thx.

Sercan

 

 

Here are the details:

At the Ev.Board SW (AD9914_Setup_v1.0.4595.26695)

  Under CONTROL tab: Only the below parameters are set

     * SYNC CLK enable : Checked

     * Enable sine output: Checked

     * Fast recovery : Checked

     * OSK Enable & Ext.OSK Enable : Checked , Ext.OSK Pin is active

 

  Under PROFILES tab:

     * Enable is unchecked

     * Selected profile is 0 (where this option is inactive)

     * Freq: 400 MHz

     * Phase: 0

     * Amp: Max (FFF)

 

  Under SWEEP tab:

     * Enable is checked

     * When Freq. is programmed

          - 390 to 410 MHz

          - Step size (rising/falling) : 100 KHz

          - Ramp rate (rising/falling) : 10 / 100 us

          - Freq. Jump: Disabled

       OBSERVATION is: 6,7 us (or 67 us for 100 us)

     * When Amp. is programmed

          - 0,1 to 1,0 V

          - Step size (rising/falling) : 0,01 V (or 0.1 V)

          - Ramp rate (rising/falling) : 10 us (or 100 us)

       OBSERVATION is: 6,7 us (or 67 us for 100 us)

 

  Under MODULUS tab:

     * Enable is unchecked

 

----Sure, some above setting were done when their related step had occurred.

----Initial master reset & DAC calibration were done.

Outcomes