AnsweredAssumed Answered

HDMI not working in newer designs

Question asked by milosoftware on Jan 21, 2014
Latest reply on Aug 18, 2014 by milosoftware

I am using the reference design here:

https://github.com/analogdevicesinc/fpgahdl_xilinx

 

So far, I've been using tag 0a90b0d42efa2c571e1dd3a038a00f974d6b3e5f as basis for my design, compiled using the 14.4 toolchain.

One project uses a fork of this design under Vivado, which also works fine.

 

I was attempting to upgrade to the Xilinx 14.6 toolchain, but that forces me to choose between two evils.

 

If I stick to the design that works, the 14.6 toolchain refuses to compile it and bails out with errors that a software guy like me (who knows just enough to write a blinking LED in vhdl) can't understand.

 

If I build the current HEAD, it compiles, but the image appears to be no longer compatible with the drivers in the xcomm_zynq branch. The HDMI output does not produce anything (screen remains off), though the driver loads just fine and detects the monitor's presence and resolution settings.

 

I tried building the "first" 14.6 compatible version,6e9926109ed58089cf40eaaeb8e05166e7a68e4f which compiles in 14.6 but also doesn't produce HDMI output.

 

Then I tried 5bd82b7bde98de85b8627b7f117861c9bbe9da6f which appears to be just before some changes in the vdma and hdmi cores, but this one doesn't compile in 14.6 either.

 

I've been using a fork of the xcomm_zynq branch in the adi kernel. I noticed no changes to the hdmi driver there in the past months though.

Outcomes