AnsweredAssumed Answered

set  ADV7611 about WXGA4

Question asked by chongzi on Dec 28, 2013
Latest reply on Dec 30, 2013 by raymondcarter

Hi,

       I want adv7611 work with WXGA4(1366X768@60HZ).I set registers as:

         IO part:

            {0x01, 0x06},  // Prim_Mode =110b HDMI-GR

            {0x02, 0xF5},  // Auto CSC, YCrCb out, Set op_656 bit

            {0x03, 0x80},  // 24 bit SDR 444 Mode 0

            {0x05, 0x24},  // AV Codes Off 0x28 0x24

            {0x06, 0xA6},  // Invert VS,HS pins

            {0x0B, 0x44},  // Power up part

            {0x0C, 0x42},  // Power up part

            {0x14, 0x7F},  // Max Drive Strength

            {0x15, 0x80},  // Disable Tristate of Pins

            {0x19, 0x80},  // LLC DLL phase

            {0x33, 0x40},  // LLC DLL enable

       CP part:

           {0x7b, 0x04},//AV_POS_SEL

           {0x8F, 0x02},//CH1_FR_LL

           {0x90, 0x56},//CH1_FR_LL

           {0x91, 0x00},//INTERLACED

           {0xAB, 0x31}, //CP_LCOUNT_MAX

           {0xAC, 0xE0},//CP_LCOUNT_MAX

           {0xBA, 0x01},//HDMI_RUN_EN

           {0xC9, 0x01},//DIS_AUTO_PARAM_BUFF

        HDMI part:

          {0x9B, 0x03},  //ADI recommended setting

          {0xC1, 0x01},  //ADI recommended setting

          {0xC2, 0x01},  //ADI recommended setting

          {0xC3, 0x01},  //ADI recommended setting

          {0xC4, 0x01},  //ADI recommended setting

          {0xC5, 0x01},  //ADI recommended setting

          {0xC6, 0x01},  //ADI recommended setting

          {0xC7, 0x01},  //ADI recommended setting

          {0xC8, 0x01},  //ADI recommended setting

          {0xC9, 0x01},  //ADI recommended setting

          {0xCA, 0x01},  //ADI recommended setting

          {0xCB, 0x01},  //ADI recommended setting

          {0xCC, 0x01},  //ADI recommended setting

          {0x00, 0x00},  //Set HDMI Input Port A

          {0x83, 0xFE},  //Enable clock terminator for port A

          //{0x6C, 0x02},

          {0x6F, 0x0C},  //ADI recommended setting

          {0x85, 0x1F},  //ADI recommended setting

          {0x87, 0x70},  //ADI recommended setting

          {0x8D, 0x04},  //LFG

          {0x8E, 0x1E},  //HFG

          {0x1A, 0x8A},  //unmute audio

          {0x57, 0xDA},  //ADI recommended setting

         {0x58, 0x01},  //ADI recommended setting

         {0x75, 0x10},  //DDC drive strength

     

        Measure Hs ,Vs and LLC.Hs is 47.7KHZ. Vs is 60HZ. Colock is 38.3MHZ. Colock is incorrect,should be 85.75MHZ.

         How to solve the question? Help me, please.

   

        Regards,

Outcomes