AnsweredAssumed Answered

Compiler Error on .IMPORT

Question asked by Gasha on Dec 25, 2013
Latest reply on Dec 27, 2013 by Gasha
I recently got CCE Studio. I tried to import old Visual DSP project but it did not work for me. I was getting
error I could not figure out. So, I decided to start a project from scratch and copy source files. However,
when I tried to compile it, I got an error in an assembler source file that uses ".IMPORT Vars.h"" directive.
It says it can not open "Vars.h" file, although it is in the project folder. Here is the error message:
'Building file: ../Func.asm'
'Invoking: CrossCore SHARC Assembler'
easm21k.exe -file-attr ProjectName="APE_CCS" -proc ADSP-21369 -si-revision 0.2 -g -D_DEBUG -i"D:\Gasa\PROJECTS\Bill\APE\Software\APE_CCS\system" -gnu-style-dependencies -MM -Mo "Func.d" -o "Func.doj" "../Func.asm"
cc0005:  Catastrophic error: could not open source file "Vars.h"
1 catastrophic error detected in the compilation of "E:\Temp\acc1d082b58000\acc1d082b58001.c".
Compilation terminated.
cc3089: fatal error: Compilation failed
[Error ea1072] "../Func.asm":6 'Vars.h':
Import header file failed to compile.
Please correct the compilation errors and re-assemble.
Assembler totals: 1 error(s) and 0 warning(s)
[Warning ea1109] "command-line":1 Unable to delete pre-processor output file.: E:\Temp\Func11
This project compiled in Visual DSP without a problem. I appreciate your help.
Thank you. The whole project is attached to this post.
Gasha

Attachments

Outcomes