AnsweredAssumed Answered

AD9910 Eval software RAM loading errors

Question asked by tkloyd on Jun 23, 2010
Latest reply on Dec 12, 2012 by sitti

In my application I want to have a certain profile perform a frequency sweep, so I want to use RAM control.  My problem is that loading my RAM Data File into the RAM using the eval software seems wildly inconsistent, meaning I load my file, then perform the Read RAM to file, and the two files are never identical.

 

I've "gotten lucky" a few times where the file was written into RAM correctly, but haven't been able to identify a process that makes this work all the time.  I've tried in both RAW Hex and RAW Decimal formats, and I've tried data files of various lengths, from 12 addresses to all 1024.

 

Has anyone else had this problem?  Is there any other way to load the RAM?

 

As a sidenote, during my poking around trying to fix this, I've discovered that clicking the 'Enable Multiplier' checkbox on in the Control window while the OSK Digital Ramp Control window is open causes a fatal error for the eval software.

 

Thanks for any help,

 

Thomas

Outcomes