AnsweredAssumed Answered

Building u-boot for a blackfin 527 board using buildroot

Question asked by Soderstrom on Nov 25, 2013
Latest reply on Nov 26, 2013 by Soderstrom

Hi,

This is my first post here in these forums so I hope I am posting in the right place.

I am trying to learn some basic steps for building a toolchain, kernel and bootloader for blackfin 527 boards using buildroot.

 

I believe that I've successfully built the toolchain and kernel, however building u-boot keeps eluding me.

The only thing I feel certain of is that I am doing something wrong.

 

At first I just enabled u-boot from buildroot's menuconfig, and selected my board (bf527-ezkit), and off course I had selected target cpu as bf527.

Then when this didn't work I changed it to use a custom git repository (in case something had been fixed), the repo I choice is http://git.code.sf.net/p/adi-u-boot/code and the master branch of this git repo.

 

Both of these attempts ended the same way, where it attempts to link a non-fdpic ocject with an fdpic object.

 

I've attached the end of the build log, the the stamps from buildroot, the buildroot config and for some reason the uboot.board.depends

As I believe these are the files that will be off interest.

 

For the curios, I have tried things according to the documentation as well (https://blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:compiling)

and still receiving the same error for this particular board.

 

(I haven't tried any other boards since this is the board that I actually have)

 

Yours sincerely

Rikard Söderström

Outcomes