AnsweredAssumed Answered

Sigma Studio GUI bug

Question asked by PeterTheRed on Sep 12, 2013
Latest reply on Oct 16, 2013 by stmoeller60

Greetings,

 

I've encountered a bug a few times now in Sigma Studio, and wondering if anyone else has seen it or found a workaround.

 

Occasionally, algorithm 'blocks' become blanked-out - only their outline, name, and connections are visible, but none of their parameters.  Other blocks may not be blanked-out entirely, but their parameters are locked-out and can't be edited.  This is the case for the 'DC' blocks shown in the attachment.

 

I've tried cutting and re-pasting the entire dsp flow.  This usually restores the image of the parameter fields, but the parameters remain locked out - clicking a parameter text field simply selects the algorithm block.  I've also tried closing and re-opening both the dspproj file and Sigma Studio itself, and trying different versions of Sigma Studio (I'm using v3.8 primarily, but sometimes use v3.9-beta, as other GUI bugs relating to text display in the Hardware Control tabs seem to have been fixed there).  Closing and re-opening SS sometimes works, but not always.

 

The GUI allows zooming in and out of the schematic diagram using <ctrl+mouseWheel>.  This would be great, except that this (habitual) action seems to cause this locked-out or blanked-out behavior - not consistently, but frequently.

 

As you can imagine, its tough to get much done in SS when the GUI doesn't allow adjustments to algorithm parameters and when all the tricks above fail to resolve the issue.  Any thoughts?

 

Thanks,

 

Peter

Attachments

Outcomes