AnsweredAssumed Answered

I can't erase ADuCM360, any pointer?

Question asked by dinrail on Jul 16, 2013
Latest reply on Jul 16, 2013 by dinrail

I just got a new PCB to try out ADuCM360 again, and ran into some problem, I can't erase it, so I would appreciate it if you can give me a pointer

 

I had three previous revs of PCBs and I never had issue with programming/erasing ADuCM360.

 

This time, I don't think I change anything around the micro to affect this area, but I can't erase it any more. I compared the signal on this board with the other working ones and I didn't see any difference in the scope: RESET is high, 3.3V is solid, SWDIO and SWCLK has signal during erasing, and the JLINK's erase command returns:

 

* JLink Info: Device "ADUCM360" selected (0 KB flash, 0 KB RAM).

Set JLink Project File to "C:\Keil\Analog\examples\Adc\JLinkSettings.ini"

 

JLink info:

------------

DLL: V4.51g, compiled Jul 11 2012 20:31:55

Firmware: J-Link ARM Lite V8 compiled Jun 19 2012 14:36:11

Hardware: V8.00

S/N : 228200192

 

* JLink Info: Found SWD-DP with ID 0x2BA01477

* JLink Info: FPUnit: 6 code (BP) slots and 2 literal slots

* JLink Info: Found Cortex-M3 r2p0, Little endian.

ROMTableAddr = 0xE00FF003

 

Target info:

------------

Device: ADuCM360

VTarget = 3.358V

State of Pins:

TCK: 0, TDI: 1, TDO: 1, TMS: 1, TRES: 1, TRST: 1

Hardware-Breakpoints: 6

Software-Breakpoints: 8192

Watchpoints:          4

JTAG speed: 2000 kHz

 

***JLink Error: Can not read register 15 (R15) while CPU is running

**JLink Warning: CPU could not be halted

***JLink Error: Could not read memory location 0x20000000 when trying to clear soft RAM BP

Could not start CPU core. (ErrorCode: -1)

***JLink Error: Can not read register 20 (CFBP) while CPU is running

**JLink Warning: CPU could not be halted

***JLink Error: CPU is not halted

***JLink Error: Can not read register 15 (R15) while CPU is running

**JLink Warning: CPU could not be halted

***JLink Error: Could not read memory location 0x20000000 when trying to clear soft RAM BP

Full Chip Erase Failed!

 

I've tried two micros already, with the same result.

 

What could be wrong? Thanks for any pointer!

Outcomes