AnsweredAssumed Answered

Ethernet Application Help

Question asked by fmna on May 3, 2010
Latest reply on Feb 4, 2011 by CraigG

Hi to all!

 

This post will probably be a long one, but i'll try to explain everything i've done.

 

HARDWARE:

-ADZS-BF533-EZLITE - http://www.analog.com/en/embedded-processing-dsp/blackfin/BF533-HARDWARE/processors/product.html

-ADZS-USBLAN-EZEXT - http://www.analog.com/en/embedded-processing-dsp/blackfin/BF-EXTENDERUL/processors/product.html

-ADZS-USB-ICE - http://www.analog.com/en/embedded-processing-dsp/blackfin/USB-EMULATOR/products/product.html

-A windows XP pc with a free ethernet interface to connect to USBLAN, running wireshark

 

 

OBJECTIVE:

Make an ethernet layer, which will be the base of a proprietary real-time protocol.

 

 

Documentation read:

-VisualDSP++ 5.0 C/C++ Compiler and Library Manual for  Blackfin Processors (Revision 5.2, September 2009) (pdf, 6221 kB) (consult)

-VisualDSP++ 5.0 Device Drivers and System Services  Manual for Blackfin Processors (Revision 4.1, September 2009) (pdf, 3386  kB)

-ADSP-BF533 EZ-KIT Lite Evaluation System Manual  (Revision 3.1, September 2007) (pdf, 959 kB)

-HPUSB, USB, HPPCI Emulators User’s Guide (Revision 3.1,  September 2009) (pdf, 694 kB)

 

C:\Program Files (x86)\Analog Devices\VisualDSP 5.0\Blackfin\lib\src\lwip\contrib\ports\ADSP-Blackfin\docs\BF537EthernetDeviceDriverDesign.doc

C:\Program Files (x86)\Analog Devices\VisualDSP 5.0\Blackfin\lib\src\lwip\contrib\ports\ADSP-Blackfin\docs\SMSCLAN91C111_DeviceDriver.doc

 

 

 

After getting used to the IDE and after reading the documentation, i started to run examples:

LED's,timers, interrupts, etc

 

I felt confident with the development environment, so i ran your C:\Program Files (x86)\Analog Devices\VisualDSP 5.0\Blackfin\Examples\ADSP-BF533 EZ-KIT Lite\Power_On_Self_Test\EZ-USBLAN POST\ethernet_test.c test. I made the obvious changes to run the code on the board.

 

This example sent some packets and then finished, so i altered the code to send a specific kind and specific number of packets of my wish. Success!

The main problem is that i never could receive nothing. The lancallback function is never activated when it is supposed to receive a packet. The activity LED flashes though.

 

As it could be my changes to your code, i ran your C:\Program Files (x86)\Analog Devices\VisualDSP 5.0\Blackfin\Examples\USB-LAN EZ-EXTENDER\LAN\DNS_Client\BF533 DNS Client example.

 

As soon i ran it, it showed up DHCP requests on wireshark. It was obvious I needed a DHCP server. I installed it, and my DHCP server works by offering an IP (tested with another clients also), but "the board" keeps asking for an IP. So i think it cannot see the DHCP offer -> it isn't receiving packets.

 

Summary:

-I READ the documentation, various times, and understand it.

-I'm running your DNS_client.c example without any changes and it cannot get an IP -> can't receive a packet.

 

What do you suggest? Could it be an H/W problem? The LED flashes when there is activity on the cable!

 

Pleas help me, i'm on this months by now!!!

Outcomes