AnsweredAssumed Answered

u-Boot induced baud rate error of UART on BF561

Question asked by cthsu1 on Dec 23, 2009
Latest reply on Jan 4, 2010 by jobo23

I have ever loaded U-boot hex file (u-boot-bf561-ezkit-bypass-2009R1-rc3.hex) to Flash.

 

First, I went to "Tools-->Flash Programmer" in VDSP++5.0 and loaded the driver "BF561EzFlashDriver.dxe".
Then I loaded the hex file "u-boot-bf561-ezkit-bypass-2009R1-rc3.hex" into Flash.
So I can boot BF561 from Hyperterminal in Windows XP or minicom in Linux.

 

After that, I found my original VDSP++ project "RS-232 Cable Test" doesn't work any more so I erase all Flash.

Then project "RS-232 Cable Test" is working but I need to reduce baud rate setting of Hyperterminal to half of original setting.

Ex:

1.
In codes: "UART_init(65);" (= 115200 bps)
Hyperterminal: 57600 bps   (= half 115200 bps)

2.
In codes: "UART_init(130);" (= 57600 bps)
Hyperterminal: 28800 bps   (= half 57600 bps)

3.
In codes: "UART_init(390);" (= 19200 bps)
Hyperterminal: 9600 bps   (= half 19200 bps)

They are all working!


Today I applied the same procedure on other BF561.
I got the same result. I need to reduce baud rate setting of Hyperterminal to half of original setting.
So I think the problem is relevent to u-boot hex file the erased Flash.

Does anyone know how to solve this problem?
Thank you very much.

 

P.S.

Attached files:

(1) uClinux kernal: u-boot-bf561-ezkit-bypass-2009R1-rc3.hex

(2) Whole VDSP++ project: RS232_Test.zip

(3) Error message: Hyperterminal_Message.zip

Outcomes