AnsweredAssumed Answered

UART1 sending/receiving random characters

Question asked by NTan on May 29, 2013
Latest reply on Jun 3, 2013 by NTan

Good Day everyone!

 

     Previously, I tried sending and receiving data using UART0 and everything worked smoothly. This time, I'm trying to use UART1 by editing the previous code just a bit (the C Uart library given by EE-347 provides an easy switch from uart0 and uart1). However, when I try sending a specific character, another character is received. In this example, I'm sending 'A' but I'm receiving ú. Both the initialized baud rate for the UART1 of blackfin and hyperterminal is 57600, so I'm not quite sure why a different character is being received. From my previous observations, this may be a problem with timing? I'm just curious because the same code worked well with UART0.

 

     Can anyone help me with this problem?  UART1 pin 6 (tx) is connected to rx of the usb to rs232 cable and pin 10(rx) is connected to tx of the said cable. SW5.1 and SW5.2 are turned off to enable UART pins. I am using a BF537  Ez kit lite, silicon rev 0.3. My code is attached to this message.

 

Thank you!

Attachments

Outcomes