AnsweredAssumed Answered

ADAU1761 with out hdmi

Question asked by new_green@qq.com on May 29, 2013
Latest reply on May 29, 2013 by new_green@qq.com

Hello,I am doing my project but coming a problem.I want to use adau1761 on zedborad ,but i don't need to hdmi . I found the discuss"

adau1761 on ZedBoard(no linaro)" ,which someone asked ,and it is usefull .With the instruction,I can use ADAU1761 to play wav files. Then I remove the HDMI from the xps project ,modify the zynq-zed-adv7511.dts(remove the hdmi and modify the address of something relative with adau1761).But after inserd the sdcard to zedborad and boot suecessfully(with linaro),it shows no hdmi  like this in minicom:

 

ALSA device list:
  #0: ZED ADAU1761

 

after it completes, I run "alasctl restore -f ADAU1761.state" ,it comes:


alsactl: set_control:1464: Cannot write control '2:0:0:Mic Bias Mode:0' : Device or resource busy

alsactl: set_control:1464: Cannot write control '2:0:0:Lineout Playback Volume:0' : Device or resource busy

 

then I tried to run" aplay -D plughw:0,0 hongri.wav" ,it comes :

 

Playing WAVE 'hongri.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

 

but no sound output .

 

I don't know why ,could someone help ,thanks verymuch!

 

I've attached the boot.bin. uImage ,devicetree.dtb

Attachments

Outcomes