AnsweredAssumed Answered

ADRF6510 Eval Board software not working

Question asked by jcabsk on May 28, 2013
Latest reply on May 29, 2013 by jdobler

I got this board and the communication software. Installed the app but when I run it, does not load.

I tried on my company laptop (no admin rights) with Win 7 - 32. First I though it was a problem of asking the IT guys, but they couldn't make any better. So I tried in an old PC with Win XP and even on mine at home (Win 7 x64). In these cases I got just an error message "WindowsFormsApplication1 has stopped working".

I found that whenever I connect the board through the USB, it is unrecognized (so there is no driver). From properties I can read this:

 

USB\VID_0456&PID_7050&REV_0000

USB\VID_0456&PID_7050

 

In the installation folder there is cyusb_RFG_USB.inf with these lines:

 

;for x86 platforms

[Device.NTx86]

;%VID_XXXX&PID_XXXX.DeviceDesc%=CyUsb, USB\VID_XXXX&PID_XXXX

%VID_04B4&PID_0081.DeviceDesc%=CyUsb, USB\VID_04B4&PID_0081

%VID_0456&PID_B403.DeviceDesc%=CyUsb, USB\VID_0456&PID_B403

%VID_0456&PID_7050.DeviceDesc%=CyUsb, USB\VID_0456&PID_7050

%VID_04B4&PID_8613.DeviceDesc%=CyUsb, USB\VID_04B4&PID_8613

 

That seem to match the PID and VID read from the actual device. I put this because of a related post which I tried to follow but didn't help

 

Browsing for a driver took me to some places and files that did not work so far. Isn't there a proper dummy-proof driver installer?

 

Can anybody throw any light (or advice or file or link) on me?

Outcomes