AnsweredAssumed Answered

AD5292BRUZ-50 is not resetting ?

Question asked by Pratheep on May 3, 2013
Latest reply on May 6, 2013 by Pratheep

Hi,

I am using ad5292 in rheostat mode. I configured the spi correctly and able communicate with ad5292. After power up the resistance is not comes to 50% of full scale value as mentioned in datasheet. I tried the below points for past three days but still unable to move next step.

 

1. Tried to reset the device by command (0x1000), [reset pin and Vlogic is tied]

 

2. Tried to write to RDAC as per sequence in table12 in datasheet, but no change in resistance and when use the command 0x0800 to read RDAC i get same command(0x0800) as reply on next frame.

 

3. Referred lots of blogs and discussions then modified the write sequence like putting delays, putting write command (0x0500) twice, putting in shutdown mode, etc.

 

4. Ensured SCLK, CS, CPOL & CPHA status as per datasheet & discussions

 

5. Replaced the device with new one.

 

Still i can't able to get any resistance values between wiper(wiper and terminal B is tied) and terminal A point and when i try to measure on multimeter i show open at all the conditions above. i am applying 12V at terminal A, wiper & terminal B is grounded and terminal A remains same in all above conditions. I don't know why i am not getting even 50% resistance at power up / reset.

Outcomes