AnsweredAssumed Answered

Problems loading U-boot

Question asked by NTan on May 1, 2013
Latest reply on May 13, 2013 by NTan

Good Day Everyone!

     I'm trying to set up my blackfin for uClinux and am following the guide here: http://docs.blackfin.uclinux.org/doku.php?id=quick-start:bf537-stamp. My board is a BF537 EZ Lite kit. I have already set up my development host (Laptop running Ubuntu 12.04) and installed the needed terminal programs.

 

     Now, I'm trying to load u-boot. I have applied the following changes to my board:

    • SW16: Set the boot mode switch to position 7
    • JP9: Remove the UART loop back jumper
    • SW4: Set UART switch to {OFF,ON,OFF,ON}
    • SW6: Set flash switch to {ON,ON,ON,ON}

 

I'm having a problem with the next step: "Now with your terminal emulator running, press the reset button (SW9) a few times. You should see no output. Press the space bar a few times and you should see one or two random bytes come back. Hit the reset button a few times again, and try the space bar again. If you still see a few bytes come back, then everything is connected properly. Now quit out of your terminal emulator and once it has exited, hit the reset button a few more times."

 

     I have verified that my usb to serial cable is working through $ dmesg | grep tty which gives the following result:

2.png

     I have also tried both Kermit and Minicom but I still get no output. Below are the settings/output for minicom:

5.png 4.png

1.png

 

... and for Kermit:

8.png

I have also tried the steps in the troubleshooting page (http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:loading#troubleshooting), but still no output.

 

Is it possible that the other jumpers/settings have an effect on the output? I have changed some of them previously. Also, I have an ethernet patch cable connected from my laptop to the board as instructed in the documentation. Have I missed any steps ?

 

Thank you!

 



 


Outcomes