AnsweredAssumed Answered

Image capture with BF537 EZ Lite Kit

Question asked by NTan on Apr 24, 2013
Latest reply on May 29, 2013 by ColinJ

Good Day Everyone!

 

     I currently have a BF537 EZ Lite Kit, an AV Extender, and a CMOS camera (Omnivision's OV7720). I'm trying to capture an image, and for this I have tried the sample code given in the Visual DSP installation (under AV Extender), Video Sensor Input (C). However, it only provides examples for the OV6630, MT9V022, and LM9618. I tried adjusting some settings of the OV6630 so that it would fit the OV7720 (for example pixel per line and lines per frame). However, when I run the program, all I got was a black image. When I changed the Image format, the image changed to a solid green image, so I assumed here that the camera was working and that there was something wrong with my settings.

 

The settings that I used are as follows:

     #ifdef OV7720

     #define POL_C                               0x4000

     #define POL_S                               0x0000

     #define PIXEL_PER_LINE 640

     #define LINES_PER_FRAME 480

     #define DATALEN                              0x3800

     #define          DataPacking                    0x0000

     #define PPICOUNT 639

     #endif

 

I'm not sure however of the values for  POL_C, POL_S, DATALEN, DataPacking, and PPICOUNT as I'm not sure of where to get them from.

Attached is the original project and the datasheet for the OV7720.

 

However, I would also appreciate any other ideas and suggestions on how to capture images with the BF537. I'm a beginner so I don't really know where to start.

 

Thank you!

Outcomes