AnsweredAssumed Answered

ADSP-21479 fails to boot from SPI Flash

Question asked by phychem on Apr 19, 2013
Latest reply on Apr 20, 2013 by phychem

Hi,

 

I met an issue that ADSP-21479 fails to boot from SPI Flash M25P16. Details:

1. DSP's SCLK (DPI_P03) connects to the Flash's SCLK via a 22Ohm resistor in series, no pull down or pull up resistors;

2. Other SPI signals route to the Flash directly using the default routing (Same as Ezkit). The Flash is the only device on the bus;

3. IAP code can erase, program and read Flash without any issue;

4. Visual DSP++ (V5.0)'s Flash programmer tool can erase and program the Flash without any issue;

5. Flash content was send through UART to PC (by customer function) for comparison and it was all correct;

6. HPUSB emulator can connect and debug to the target board when Flash is empty;

7. After Flash was programmed with target code ldr file (8bit hex, SPI flash option as loader), the DSP did not start after powered up (LED did not blink as it should. It worked using the same code in emulator debug mode). Programming method was either VDSP Flash programmer tool or IAP code;

8. After it failed to boot, the target DSP can be connected to PC via HPUSB emulator. However the memory content was unable to display (and failed in JTAG frequency test). And code can not be loaded correctly.

 

Attached the waveform captured by oscilloscope trigger function... , MISO has no valid output levels (seems to be between 2.5v to 3.3v).

 

I have been using this DSP for two years and it worked fine, This is a new PCB design but the DSP part is almost unchanged. Feel weired.. , I would be appreciate if anyone has any clue on this..

 

 

 

Best Regards,

Phy

Outcomes