AnsweredAssumed Answered

Problems with ftpd servers

Question asked by LukasW on Mar 21, 2013
Latest reply on Mar 22, 2013 by LukasW

Hello,

i need a ftp server for my BF537-Stamp. It must support chroot and user-login, anonymous must be disabled. As far as i can see busybox ftpd does not support non-anonymous connections, so i can't use it.

The most  auspicious lightweight replacement was ftpd from inetutils, but chroot setup with fdpic is quiet horrible (need /bin, /lib, /etc in chroot) and even after that all files downloaded via ftp are empty - this is not a feasible solution.

So i tried proftpd. This works very well, but it is not lightweight: ~500k binary is pretty much (my busybox is only 250k) and i do not use most of the functionality.

 

vsftpd is better in this focus (~100k). After adding a no-mmo patch (replace fork with vfork) it compiles FDPIC, but when i run it on the device i get

root:/> vsftpd
500 OOPS: mprotect

I have no idea what this message is about and where to search for the problem. Do you have any suggestions?

(Sorry for missing strace output, cant download it)

Iam using buildroot 2012R2 branch with precompiled toolchain 2012R1.

Outcomes