AnsweredAssumed Answered

Building target fpr BF537 fails

Question asked by LukasW on Feb 25, 2013
Latest reply on Feb 26, 2013 by Aaronwu

Hello there,

i have a device based on BF537-stamp here running uClinux 2010RC1 and i want to update.

The ADI Blackfin homepage provided information, that BF5xx is now supported by buildroot project, too. So i decided to test it - without any luck.

 

The steps (as described in http://docs.blackfin.uclinux.org/doku.php?id=buildroot:build-system:build_a_target):

First i cloned buildroot from GIT:

     > git clone git://blackfin.uclinux.org/git/buildroot; cd buildroot

     > git checkout -b 2012R2 remotes/origin/2012R2

     > git submodule update --init

Then the subdir linux/linux-2.6.x did not exist. Suppose its linux/linux-kernel now.

After changing all subdirectories to 2012R2 ive downloaded http://blackfin.uclinux.org/gf/download/frsrelease/588/10170/blackfin-toolchain-2012R2-RC2.x86_64.tar.bz2 toolchain and set bin directories to my $PATH.

Then i run

     > make bf537-stamp_defconfig

and

     > make

 

Result was, "gdbserver configure script detected that gcc can not generate executeables". config.log said

as: unrecognized option '-mcpu=bf537'

 

So i tried toolchain snapshot http://blackfin.uclinux.org/gf/download/frsrelease/344/6728/blackfin-toolchain-uclinux-SVN.x86_64.tar.bz2 .

With that the build (make clean; make) failed on busybox-1.20.2 with the message

     coreutils/id.c:69:2: Fehler: #error "Sorry, you need at least uClibc version 0.9.30 for id applet to build"

     coreutils/id.c: In function ‘get_groups’:

     coreutils/id.c:131: warning: implicit declaration of function ‘getgrouplist’

 

Google told me, that bug was fixed in 2010... or maybe not? I played arround with some other buidroot trees, toolchains and even older busybox versions without any advancement.

 

What am i doing wrong?

Outcomes