AnsweredAssumed Answered

FMCcoms tutorial issue with IIO scope

Question asked by duanra22 on Feb 15, 2013
Latest reply on Feb 25, 2013 by mhennerich

I try to follow the tutorial to test my fmcomms board on zed_board

http://wiki.analog.com/resources/eval/user-guides/ad-fmcomms1-ebz/software/linux/zynq

 

fist I have this kind of message on my console:

does modprob and hard-IRQ message are normal?

 

------------------------------------------------------

 

EXT4-fs (mmcblk0p2): recovery complete

EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)

VFS: Mounted root (ext4 filesystem) on device 179:2.

Freeing init memory: 152K

init: Failed to create pty - disabling logging for job

init: Temporary process spawn error: No space left on device

modprobe: FATAL: Could not load /lib/modules/3.6.0-02192-gf7202e6/modules.dep: No such file or directory

 

* Starting mDNS/DNS-SD daemon                                           [ OK ]

* Starting bluetooth daemon                                             [ OK ]

* Starting configure network device security                            [ OK ]

* Starting configure network device                                     [ OK ]

* Starting Mount network filesystems                                    [ OK ]

* Starting Failsafe Boot Delay                                          [ OK ]

* Stopping Mount network filesystems                                    [ OK ]

* Stopping Failsafe Boot Delay                                          [ OK ]

* Starting bluetooth daemon                                             [ OK ]

* Starting CUPS printing spooler/server                                 [ OK ]

* Stopping configure virtual network devices                            [ OK ]

* Starting System V initialisation compatibility                        [ OK ]

* Starting modem connection manager                                     [ OK ]

* Starting configure network device security                            [ OK ]

* Starting bluetooth daemon                                             [ OK ]

* Starting Bridge socket events into upstart                            [ OK ]

* Starting bluetooth daemon                                             [ OK ]

* Starting network connection manager                                   [ OK ]

* Starting bluetooth daemon                                             [ OK ]

speech-dispatcher disabled; edit /etc/default/speech-dispatcher

 

saned disabled; edit /etc/default/saned

Last login: Thu Jan  1 00:00:16 UTC 1970 on tty1

* Stopping System V initialisation compatibility                        [ OK ]

* Starting System V runlevel compatibility                              [ OK ]

* Starting automatic crash report generation                            [ OK ]

* Starting LightDM Display Manager                                      [ OK ]

* Starting save kernel messages                                         [ OK ]

* Starting anac(h)ronistic cron                                         [ OK ]

* Starting regular background program processing daemon                 [ OK ]

* Stopping System V runlevel compatibility                              [ OK ]

* Starting crash report submission daemon                               [ OK ]

* Stopping System PulseAudio sound server                               [ OK ]

* Stopping save kernel messages                                         [ OK ]

 

======================================================

[ INFO: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected ]

3.6.0-02192-gf7202e6 #1 Tainted: G        W

------------------------------------------------------

kworker/1:1/16 [HC0[0]:SC0[0]:HE0:SE1] is trying to acquire:

(prepare_lock){+.+.+.}, at: [<c0280984>] clk_round_rate+0x1c/0x40

 

and this task is already holding:

(&(&lp->lock)->rlock){-.-...}, at: [<c0206804>] xemacps_adjust_link+0x1c/0x220

which would create a new lock dependency:

(&(&lp->lock)->rlock){-.-...} -> (prepare_lock){+.+.+.}

 

but this new dependency connects a HARDIRQ-irq-safe lock:

(&(&lp->lock)->rlock){-.-...}

... which became HARDIRQ-irq-safe at:

  [<c005b658>] __lock_acquire+0x730/0x1b80

  [<c005cf08>] lock_acquire+0x60/0x74

  [<c034c1b0>] _raw_spin_lock+0x40/0x50

  [<c0208028>] xemacps_interrupt+0x20/0x320

  [<c0069504>] handle_irq_event_percpu+0x28/0x170

  [<c0069688>] handle_irq_event+0x3c/0x5c

  [<c006c0a8>] handle_fasteoi_irq+0xc8/0x114

  [<c0068f68>] generic_handle_irq+0x20/0x30

  [<c000e0bc>] handle_IRQ+0x78/0xb8

  [<c0008460>] gic_handle_irq+0x38/0x5c

  [<c000d59c>] __irq_usr+0x3c/0x60

 

 

After, Linaro start succefully

 

I do not succed to do the

Enable xf86-video-modesetting Xorg driver

 

because I don't have /etc/X11/xorg.conf file

 

sudo sed -i 's,load-module module-dbus-detect,load-module module-dbus-detect tsched=0'

return

sed: -e expression #1, char 73: unterminated `s' command

 

finaly, I download IIO scop

but the software doesn't work properly


after starting scop application try to open /sys/bus/iio/devices/iio:device5/i_dac_fs_adj

bus in ..../device5 directory I have only out_altvoltage_xxxx and out_voltagexxx files

 

Can you help me to resolve all this issue?

 

regards,

 

Arnaud

Outcomes