AnsweredAssumed Answered

Are ADC0 & ADC1 in M360 truly the same?

Question asked by gmthomas on Feb 15, 2013
Latest reply on Feb 15, 2013 by gmthomas

Hi,

 

We have an M360 measuring a thermocouple on Ain2/Ain3 using ADC1 with no problems. We also measure a Pt100 voltage on Ain4/Ain5 using ADC0.

 

Using a Rev C3V chip ADC1 works fine but ADC0 seems to take about 1.5 seconds for the value to drop from full scale to the correct 13mV result. If we connect ADC0 to Ain2/Ain3 we get the same result as ADC1.

 

Using a Rev D30 chip, with no change in firmware, ADC1 works fine but ADC0 always returns full scale. If we connect ADC0 to Ain2/Ain3 we still get full scale.

 

We are using an external 1.25V reference via the EXTREF2 inputs and the Pt100 is between 5K resistors to VRef and ground. Both ADC inputs are via external analogue multiplexers to sample multiple channels, which we have proved are working correctly.

 

Are the two ADCs truly the same? Any hints as to why ADC0 behaves so differently? We have triple checked all the register settings and the firmware is the same in each case.

 

Cheers

 

Glyn

Outcomes