AnsweredAssumed Answered

"Invalid CPU Type" ERROR msg on building uclinux-dist 2011R1

Question asked by ShutEyeThinkin on Feb 6, 2013
Latest reply on Feb 8, 2013 by sonic

A few weeks ago, I downloaded and installed the ToolChain 2012R2, and, the uclinux-dist 2011R1 onto my Ubuntu LinuxBox.

I made quite a few updates, transferring many mods from a former project. When trying to make it, I get an error msg.

 

So, I decided to go back to the raw, unmodified uclinux-dist, and make it, and see if I get the same error. Sure enough, I do.

I ran 'make menuconfig' using only the defaults', then executed 'make'. It works for a few minutes, then I get an error message:

 

--------------------------------------------------------------------------

make[1]: Entering directory `/home/smv/blackfin/sa2912/uclinux-dist/linux-2.6.x'

     .

     .

     .

  UIMAGE  arch/blackfin/boot/vmImage.gz

  CC      fs/lockd/lockd.mod.o

  CC      fs/nfs/nfs.mod.o

  CC      fs/nls/nls_base.mod.o

 

Invalid CPU Type - valid names are: alpha, arm, x86, ia64, m68k, microblaze, mips, mips64, ppc, s390, sh, sparc, sparc64

Usage: /usr/local/bin/mkimage -l image

          -l ==> list image header information

       /usr/local/bin/mkimage [-x] -A arch -O os -T type -C comp -a addr -e ep -n name -d data_file[:data_file...] image

          -A ==> set architecture to 'arch'

          -O ==> set operating system to 'os'

          -T ==> set image type to 'type'

          -C ==> set compression type 'comp'

          -a ==> set load address to 'addr' (hex)

          -e ==> set entry point to 'ep' (hex)

          -n ==> set image name to 'name'

          -d ==> use image data from 'datafile'

          -x ==> set XIP (execute in place)

make[2]: *** [arch/blackfin/boot/vmImage.gz] Error 1

make[1]: *** [vmImage] Error 2

make[1]: *** Waiting for unfinished jobs....

     .

     .

     .

-------------------------------------------------------------------------

 

I have not been successful in locating the source of this problem.

I attached the entire terminal printout of the 'make' session.

 

Thanks for any help.

 

ShutEyeThinkin

Outcomes