AnsweredAssumed Answered

BF526-EZ-Board u-boot

Question asked by tabbi on Dec 7, 2012
Latest reply on Dec 13, 2012 by Aaronwu

Hi,

 

I am new user and I have big problem with Blackfin BF526. My default configuration looks the same as http://docs.blackfin.uclinux.org/doku.php?id=hw:boards:bf526-ezbrd

 

So I connect serial cabel to UART 1 and set SW1 to 8. I download u-boot-bf526-ezbrd-SVN-fec3c973d3d27c70388df3b137f1f37ecb00c475.tar.bz2 from http://blackfin.uclinux.org/gf/project/u-boot/frs/ and unpack this archive. I am using LdrViewer. I choose uart.ldr from archive and I fallow all the instructions from http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:loading

I have the same result as on that page. But when I close LdrViewer and try to connect via Putty I have no response from u-boot ?? I have no idea why ? I still have set SW1 to 8.

 

I tried do simmilar things to upload u-boot on Linux using kermit the final result always is:

 

$ bfin-uclinux-ldr -l /tftpboot/u-boot.ldr /dev/ttyUSB0 && kermit -l /dev/ttyUSB0 -b 57600 -C connect

Loading LDR /tftpboot/u-boot.ldr ... OK!

Opening /dev/ttyUSB0 ... OK!

Configuring terminal I/O ... OK!

Trying to send autobaud ... OK!

Trying to read autobaud ... OK!

Checking autobaud ... OK!

Autobaud result: 115200bps 49.766mhz (header:0xBF DLL:0x1B DLH:0x00 fin:0x00)

Sending blocks of DXE 1 ... [1/2] [2/2] OK!

Sending blocks of DXE 2 ... [1/6] [2/6] [3/6] [4/6] [5/6] [6/6] OK!

You may want to run minicom or kermit now

Quick tip: run 'ldrviewer <ldr> <tty> && minicom'

Connecting to /dev/ttyUSB0, speed 57600

Escape character: Ctrl-\ (ASCII 28, FS): enabled

Type the escape character followed by C to get back,

or followed by ? to see other options.

----------------------------------------------------

 

But ofc when i try to type 0 I dont have response from u-boot so something like this "bfin> version". I tried to compile u-boot on linux and upload compiled .ldr file but the result is the same as above.

 

Why i cannot upload u-boot ?? What am I doing wrong ? Thanks for all answers.

Outcomes