AnsweredAssumed Answered

Compiling the kernel -- Error?

Question asked by csiggaard on Nov 28, 2012
Latest reply on Dec 2, 2012 by csiggaard

Hi

 

It seems like the compilation of the user directory of the kernel fails with Make error 2

 

CC [M]  /home/csj/BlackfinKernel/blackfin-linux-dist/user/blkfin-apps/corebld/test_module/dualcore_test.o

  Building modules, stage 2.

  MODPOST 1 modules

  CC      /home/csj/BlackfinKernel/blackfin-linux-dist/user/blkfin-apps/corebld/test_module/dualcore_test.mod.o

  LD [M]  /home/csj/BlackfinKernel/blackfin-linux-dist/user/blkfin-apps/corebld/test_module/dualcore_test.ko

make[6]: Leaving directory `/home/csj/BlackfinKernel/blackfin-linux-dist/linux-2.6.x'

make[5]: Leaving directory `/home/csj/BlackfinKernel/blackfin-linux-dist/user/blkfin-apps/corebld/test_module'

make[4]: Leaving directory `/home/csj/BlackfinKernel/blackfin-linux-dist/user/blkfin-apps/corebld'

make[3]: Leaving directory `/home/csj/BlackfinKernel/blackfin-linux-dist/user/blkfin-apps'

make[2]: Leaving directory `/home/csj/BlackfinKernel/blackfin-linux-dist/user'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/csj/BlackfinKernel/blackfin-linux-dist/user'

make: *** [subdirs] Error 1

 

I have tried both default settings and tried a set of suggested settings (for the BF537) both fails - is there some out there who have tried this?

I have tried to remove the user dir - and the the compilation works - however I do need this to I will need to get this fixed.

 

FYI

The compilation is done on i386 32 bit platform, Ubuntu 12.04 LTS - toolchain seems to be properly installed - compiling the u-boot works - and the uboot runs without problems on the bf561 ezlite platform. Also both xconfig and menuconfig works without any problems.

 

Best Regards

Carsten Siggaard

Outcomes