AnsweredAssumed Answered

USB OTG problem

Question asked by alpkrs on Jul 30, 2009
Latest reply on Jul 31, 2009 by alpkrs

Hi all,

 

Currently I am working on USB examples of EZ-Kit. I have tried to run bulk_loopback_app, mass_storage_app, Example 5: USB Project and a usb project of ours with no success. I have read all readme files of relative projects; checked switch and jumper settings. When I connect EZ-Kit Lite's USB cable I see device is in MS Device Manager but after that point I can not access from any Windows application, even with hostapp.exe. It say that "Detected 0 Blackfin USB devices" . Simillarly when I run getting started example "Example 5: USB Project" it outputs "USB Mass Storage Device ready to be connected to PC" to the console window of VisualDSP++. But when I connect usb cable nothing changes. So I guess EZ-Kit is never configured by the host. Simillarly "ClientCallback" function is never get called. I am using VDSP++ 5.0 and working on ADSP-BF548 EZ-KIT Lite rev 1.4 with silicon rev 2.0. Is there something that I miss? Any suggestions? Or any thing else that I have to configure?

Thanks in advance

 

Alper

Outcomes