AnsweredAssumed Answered

Broken ADI syntax parser in CCES 1.0.1?

Question asked by Phonon on Nov 1, 2012
Latest reply on May 27, 2013 by Caroll

Hi all,

 

I'm having an issue with CrossCore Embedded Studio parsing my source files for the Eclipse editor. In particular, when declaring a variable with the section keyword, e.g. section ("seg_dmda") int x = 2;, CCES highlights it and claims that it's wrong syntax:

CCES error.png

What I've tried:

  1. Firstly, the project builds and runs just fine. This code is parsed correctly by the compiler.
  2. I tried turning off all parsers other than CrossCore Embedded Studio Error Parser in both global settings and project setting.
  3. I tried using the #pragma section ("blah") int x=2; and even though the editor did not complain on that particular line, it still said on the next line that x was undefined. This also build without errors.
  4. I read the manual and the manual said that doing this is correct.

 

Is this a bug? Have I missed a setting in CCES? Are we for whatever reason discouraged to use this syntax?

 

UPDATE:

I just opened a project that came with EZ-Board 21469 BSP, and the same syntax highlighting but occurs with ddr2_test.c source file. I'm pretty sure this confirms it as a bug. Thoughts?

Outcomes