AnsweredAssumed Answered

U-boot Netconsole doesn't working on BF518

Question asked by thesilent on Jul 2, 2012
Latest reply on Jul 4, 2012 by thesilent

Hi,

 

I'm trying to enable U-boot Netconsole for Blackfin BF518; I've followed this AD guide but I'm not able to see anything in the output terminal.

 

However, when I try to input commands using "netconsole" helper script, I see on my board Ethernet LEDs blinking (a clear sign of working network activity).

Intrigued by this fact, I've used Wireshark to intercept UDP traffic: I'm able to see the commands I've sent and the output of that commands.

I need some assistance to understand where is the communication problem; I've tried also netcat as netconsole alternative (with this syntax: "nc -lu 6666 &" and "nc -u 192.168.x.x 6666") with the same results.

 

P.S.: I'm using U-Boot 2010.06 (ADI-2010R1-RC2); I've tried to update to newer versions (like 2011 and 2012 branches) but the problem persists.

 

Thanks in advance for your help.

 

Note: I've tried the same setups on the ufficial Board BF518F-EZBRD and I've obtained the same results with U-Boot 2011.09 (ADI-2011R1). Il messaggio è stato modificato da: Matteo Smania

Outcomes